Error message
Purchase journal X not found. Please update your connection configuration.Affected ERP integrations
Exact Online
Cause
This error typically indicates an issue with the integration setup, specifically concerning the purchase journal configuration. During the connection process, a purchase journal must be selected for Payhawk to use when exporting expenses.
If this selection is skipped or fails to save, which must generally not happen due to validation in the setup wizard, or if the previously selected journal has since been deleted or renamed in Exact Online, the integration will not be able to locate the required purchase journal.
When Payhawk attempts to export an expense, it cannot find the specified purchase journal, which results in this error.
Solution
To resolve this issue:
In the Payhawk Web Portal, go to Settings > Integrations > Exact Online.
Click on its three-dot menu and select Disconnect.
Initiate the connection process again.
In the setup wizard, follow the steps to select:
A valid Purchase Journal that exists in your Exact Online account.
Alternatively, select an A/P account which will allow Payhawk to create the necessary purchase journal on your behalf.
Complete the connection and save your configuration.