Failed to export into Exact Online. Vendor A/P account not found.

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Error message

Vendor A/P account not found. Please update your connection configuration.

Affected ERP integrations

  • Exact Online

Cause

This error typically indicates an issue with the integration setup, specifically concerning the purchase journal and the associated Accounts Payable (A/P) account. During the connection process, a purchase journal is required. If this selection is skipped or fails to save, which must generally not happen due to validation in the setup wizard, the integration will not know which A/P account to use for posting vendor bills.

When Payhawk attempts to export an expense, it cannot find the necessary A/P account linked to a purchase journal, which results in this error.

Solution

To resolve this issue:

  1. In the Payhawk Web Portal, go to Settings > Integrations > Exact Online.

  2. Click on its three-dot menu and click on Disconnect.

  3. Initiate the connection process again.

  4. In the setup wizard, select:

    • A valid Purchase Journal from your Exact Online account.

    • Alternatively, an A/P account which will allow Payhawk to create the necessary journal on your behalf.

  5. Complete the connection and save your configuration.