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Employee [email] not found

How to resolve the issue of missing employee when exporting data to Exact, Business Central, NetSuite, QuickBooks, and DATEV?

Updated over a week ago

Error message

Employee [email] not found.

Relevant ERP integrations

  • DATEV

  • Exact Online

  • MS Business Central

  • Oracle NetSuite

  • QuickBooks Online

Cause

When exporting expenses as expense reports, Payhawk uses the expense owner as the corresponding employee in Oracle NetSuite. The system searches for the employee based on their External ID, which can be found in Payhawk's Employees app or in the ERP. If no External ID is configured, the system will attempt to match the employee using their email address in the ERP. However, if an External ID is set, Payhawk will not search by email. Additionally, the employee must be assigned to the connected subsidiary in Oracle NetSuite.

For example, the Employee test@test.com not found error indicates that the expense owner's email is test@test.com, but no employee with this email exists in Oracle NetSuite. If an External ID is configured for the employee, the error means that no employee with the specified External ID was found in Oracle NetSuite.

Solution

Create an employee with the specified email in Oracle NetSuite, or assign the correct External ID to the employee in Payhawk, then try exporting again.

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